Back to overview
Downtime

mixus.ai, app.mixus.ai, and 2 other services are down

Oct 20 at 11:13am IDT
Affected services
mixus.ai
app.mixus.ai
app.mixus.ai/api/
Database Health

Resolved
Oct 20 at 01:00pm IDT

mixus.ai, app.mixus.ai, app.mixus.ai/api/, and 1 other resource recovered.

Created
Oct 20 at 11:13am IDT

mixus.ai, app.mixus.ai, app.mixus.ai/api/, and 1 other resource went down.